Ticket #1653 (closed Bugs: fixed)

Opened 8 years ago

Last modified 5 years ago

wave executable erroneously required for build of function_types lib

Reported by: stacie@… Owned by: t_schwinger
Milestone: Boost 1.36.0 Component: function_types
Version: Boost Development Trunk Severity: Problem
Keywords: wave, build Cc:


Feb 21 build of 1.35 on HP-UX 11.23 using GCC. NO zlib of bzlib built:

These fail with this error: $BOOST_ROOT/dist.bun/.wave: not found

failed Jamfile<$BOOST_ROOT/libs/function_types/build>.wave

then one of these builds





Change History

comment:1 Changed 8 years ago by grafik

  • Owner set to t_schwinger
  • Component changed from Building Boost to function_types

comment:2 Changed 8 years ago by t_schwinger

  • Owner changed from t_schwinger to vladimir_prus

Dunno how to inject that dependecy. Please help.

comment:3 Changed 8 years ago by vladimir_prus

  • Owner changed from vladimir_prus to t_schwinger

There should not be such dependency. Wave is likely not be build on any compilers, and I don't understand why wave should be used in the build process at all.

comment:4 Changed 6 years ago by vladimir_prus

  • Status changed from new to closed
  • Resolution set to fixed

As of today, nothing in function_types Jamfile is build by default, thereby fixing the original problem reported here.

I've just checked in a clean for Jamfile, in [53619], I don't think there's anything else here.

comment:5 Changed 5 years ago by danieljames

(In [70861]) Function types: Merge from trunk.


Add a comment

Modify Ticket

Change Properties
<Author field>
as closed
The resolution will be deleted. Next status will be 'reopened'

E-mail address and user name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.