Modify

Ticket #2156 (closed Bugs: fixed)

Opened 6 years ago

Last modified 5 years ago

ncurses.h and boost.asio problem

Reported by: Rubén Lara <bermejator@…> Owned by: chris_kohlhoff
Milestone: Boost 1.36.0 Component: asio
Version: Boost 1.35.0 Severity: Problem
Keywords: ncurses.h Cc:

Description

Hi all!

To reproduce:

#include <boost/asio.hpp>
#include <ncurses.h>

If i try to include both libraries together i get next error:

$ g++ -lncurses -lboost_system -lboost_thread -o main *.cpp /usr/include/boost/asio/detail/socket_option.hpp:242: error: ‘stdscr’ is not a type /usr/include/boost/asio/detail/socket_option.hpp:252: error: ‘stdscr’ is not a type /usr/include/boost/asio/detail/socket_option.hpp:252: error: expected identifier before ‘)’ token

Attachments

Change History

comment:1 Changed 6 years ago by dgregor

  • Owner changed from dgregor to chris_kohlhoff
  • Component changed from CMake to asio

comment:2 in reply to: ↑ description Changed 6 years ago by Rubén Lara <bermejator@…>

Same with svn version 47889 revision:

bermejo@BERMEJO-MOBILE ~/Proyecto/boost $ !g++ g++ -lncurses -lboost_system -lboost_thread -o main *.cpp /usr/include/boost/asio/detail/socket_option.hpp:242: error: ‘stdscr’ is not a type /usr/include/boost/asio/detail/socket_option.hpp:252: error: ‘stdscr’ is not a type /usr/include/boost/asio/detail/socket_option.hpp:252: error: expected identifier before ‘)’ token

Rubén Lara

comment:3 Changed 5 years ago by chris_kohlhoff

  • Status changed from new to closed
  • Resolution set to fixed

(In [52412]) Fix incompatibility between asio and ncurses.h due to the latter defining a macro called "timeout". Fixes #2156.

View

Add a comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.