Modify

Ticket #2621 (closed Bugs: fixed)

Opened 5 years ago

Last modified 4 years ago

filesystem library path facility still doesn't work on cygwin

Reported by: Eray Ozkural <examachine@…> Owned by: bemandawes
Milestone: Boost 1.38.0 Component: filesystem
Version: Boost 1.37.0 Severity: Problem
Keywords: cygwin Cc:

Description

There should be a previous bug report but I'd rather open a new one.

I compiled and installed defining BOOST_POSIX_API in the boost configuration and my program. I still get the following errors when I'm trying to traverse the contents of "/tmp":

terminate called after throwing an instance of 'boost::exception_detail::clone_impl<boost::exception_detail::error_info_injector<boost::filesystem::basic_filesystem_error<boost::filesystem::basic_path<std::string, boost::filesystem::path_traits> > > >'

what(): boost::filesystem::basic_directory_iterator constructor: No such file or directory: "\tmp"

So, using BOOST_POSIX_API changes exactly nothing wrt to this bug. Please help me out with this.

Best,

Eray Ozkural

Attachments

Change History

comment:1 Changed 4 years ago by bemandawes

  • Status changed from new to closed
  • Resolution set to fixed

Boost.Filesystem Version 3, which will ship with Boost release 1.44, should work more reliably with Cygwin because the API choice is now automatic and is limited to the Windows API. This is possible because modern versions of Cygwin now fully support wide character functionality such as std::wstring.

Cygwin is one of the environments being used to develop and test Boost.Filesystem Version 3.

Thanks,

--Beman

View

Add a comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.