Modify

Ticket #4091 (closed Bugs: fixed)

Opened 4 years ago

Last modified 4 years ago

iostreams cannot build against zlib 1.2.4

Reported by: Lars Viklund <zao@…> Owned by: turkanis
Milestone: Boost 1.43.0 Component: iostreams
Version: Boost Development Trunk Severity: Problem
Keywords: zlib iostreams gzio Cc:

Description

zlib 1.2.4 has recently been released and has split up some source files. The file gzio.c seems to have been split up into a bunch of gz*.c files.

As the file does not exist, the jamfile at libs/iostreams/build/Jamfile.v2 bails out hard.

A  solution from a blog seems to be to simply remove gzio from the list of source files to build. The testsuite for iostreams passes on my Windows box with VS10 RTM against trunk r61231, and my zlib_decompressor/zlib_compressor-using source builds and runs correctly.

I assume that a BBv2 guru is capable of adding some kind of condition in the Jamfile to optionally include the gzio.c file if on an older zlib.

Attachments

Change History

comment:1 Changed 4 years ago by steven_watanabe

  • Status changed from new to closed
  • Resolution set to fixed

(In [62937]) Allow building zlib 1.2.4+, using a glob to include only source files that actually exist. Fixes #4091.

View

Add a comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.