Modify

Ticket #4114 (closed Bugs: fixed)

Opened 4 years ago

Last modified 4 years ago

[regex] concept_check regression test failure on c++0x compilers

Reported by: rwebb <richard.webb@…> Owned by: johnmaddock
Milestone: Boost 1.43.0 Component: regex
Version: Boost Development Trunk Severity: Problem
Keywords: Cc:

Description

The concept_check regression test has some failures on c++0x compilers (gcc4 in c++0x mode, vc10) due to ambiguituies between boost::ref and std::ref. e.g.

 http://tinyurl.com/y5krovj

qualifying the calls with boost:: avoids the problem.

Attachments

concepts.diff Download (10.6 KB) - added by rwebb <richard.webb@…> 4 years ago.

Change History

Changed 4 years ago by rwebb <richard.webb@…>

comment:1 Changed 4 years ago by johnmaddock

  • Status changed from new to closed
  • Resolution set to fixed

(In [61430]) Disambiguate between boost::ref and std:ref etc. Suppress some new warnings from VC-10. Fix singular iterator logic (fixes VC-10 failures). Fixes #4114. Fixes #3632

View

Add a comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.