Modify

Ticket #4516 (closed Patches: fixed)

Opened 4 years ago

Last modified 3 years ago

[interprocess] linker errors running regression tests on Mingw

Reported by: Richard Webb <richard.webb@…> Owned by: igaztanaga
Milestone: Boost 1.45.0 Component: interprocess
Version: Boost Development Trunk Severity: Problem
Keywords: Cc:

Description

a bunch of the interprocess regression tests fail on Mingw with linker errors about undefined references to CoInitialize? and such. e.g.

 http://tinyurl.com/23mxkm5

changing the jamfile to link with ole32 and oleaut32 gets the tests to build.

Attachments

interprocess.diff Download (488 bytes) - added by Richard Webb <richard.webb@…> 4 years ago.
interprocess-example.diff Download (733 bytes) - added by Richard Webb <richard.webb@…> 4 years ago.

Change History

Changed 4 years ago by Richard Webb <richard.webb@…>

Changed 4 years ago by Richard Webb <richard.webb@…>

comment:1 Changed 4 years ago by Richard Webb <richard.webb@…>

Same problem applies to the examples as well as the tests.

comment:2 Changed 4 years ago by igaztanaga

  • Status changed from new to closed
  • Resolution set to fixed
  • Milestone changed from Boost 1.44.0 to Boost-1.45.0

Fixed for Boost 1.45 in release branch

comment:3 Changed 4 years ago by rwebb <richard.webb@…>

  • Status changed from closed to reopened
  • Resolution fixed deleted

The linker errors are still occuring in the comp_doc_xxx examples.

The first change in interprocess-example.diff (not applied) fixes it for me.

comment:4 Changed 3 years ago by igaztanaga

  • Status changed from reopened to closed
  • Resolution set to fixed

Patch applied in Boost 1.47

View

Add a comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.