Modify

Ticket #4606 (closed Bugs: fixed)

Opened 4 years ago

Last modified 4 years ago

[flyweight] test_intermod_holder regression test failure on Windows

Reported by: rwebb <richard.webb@…> Owned by: igaztanaga
Milestone: To Be Determined Component: flyweight
Version: Boost Development Trunk Severity: Problem
Keywords: Cc:

Description

When running the regression tests on Windows XP i see the test_intermod_holder.exe regression test process hanging around (it doesn't complete, and the test system doesn't terminate it).

If i run the test in the VC9 debugger, it goes into the call to pIWbemLocator->ConnectServer? in get_wmi_class_attribute (win32_api.hpp) and never returns (at least not in a reasonable timeframe). All of the Windows based test runners seem to have the same issue.

I don't know why this happens though.

Attachments

Change History

comment:1 Changed 4 years ago by joaquin

  • Owner changed from joaquin to igaztanaga
  • Component changed from flyweight to interprocess

Changed component to interprocess, as per discussed in  http://thread.gmane.org/gmane.comp.lib.boost.devel/208308

comment:2 Changed 4 years ago by igaztanaga

  • Status changed from new to closed
  • Resolution set to fixed

Updated Interprocess so that intermodule_singleton uses windows native shared memory.

comment:3 Changed 4 years ago by joaquin

  • Component changed from interprocess to flyweight

Changed the component back to flyweight, since this most accurately matches with the ticket's original description and further development. As of  changeset 65927 intermodule_holder is not based on boost::interprocess::named_mutex and relies instead on Boost.Interprocess internal intermodule_holder, which is not affected by the hanging problem on DLL loading time. Thanks to Ion for his work on solving this out.

View

Add a comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.