Modify

Ticket #4630 (closed Bugs: duplicate)

Opened 4 years ago

Last modified 4 years ago

[filesystem] Wave regression test failure on Mingw

Reported by: rwebb <richard.webb@…> Owned by: bemandawes
Milestone: Boost 1.45.0 Component: filesystem
Version: Boost Development Trunk Severity: Problem
Keywords: Cc:

Description

One of the Wave regression tests is failing On Mingw with the error

../boost/filesystem/v2/operations.hpp:1191:24: error: 'boost::filesystem2::create_hard_link' has not been declared

(see  http://tinyurl.com/3x3y9jj).

Looks like the "using filesystem2::create_hard_link;" on line 1191 of operations.hpp needs to be guarded with an

#if !defined(BOOST_WINDOWS_API) || defined(BOOST_FS_HARD_LINK)

as the declaration of create_hard_link iteself is.

Attachments

Change History

comment:1 Changed 4 years ago by jim@…

This change is also required for a MinGW-32 project just upgraded from boost 1.38. Thanks for doing the research.

comment:2 Changed 4 years ago by bemandawes

  • Status changed from new to closed
  • Resolution set to duplicate

Fixed by changeset 65371. See #4487.

View

Add a comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.