Modify

Ticket #4719 (closed Bugs: duplicate)

Opened 4 years ago

Last modified 4 years ago

date::day_of_week documentation is unhelpful

Reported by: russell.silva@… Owned by: matias
Milestone: To Be Determined Component: Documentation
Version: Boost 1.44.0 Severity: Problem
Keywords: Cc:

Description

The Gregorian date documentation for the day_of_week method is unhelpful. It's not clear what the return type of the method is; it's not immediately obvious what a greg_day_of_week is. The example does not help, since it does not use the method at all. It turns out that the method returns an integer, but there is no documentation as to which day corresponds to which integer return value.

http://www.boost.org/doc/libs/1_43_0/doc/html/date_time/gregorian.html#date_time.gregorian.date_class

Attachments

Change History

comment:1 Changed 4 years ago by marshall

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #4718

View

Add a comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.