Modify

Ticket #6134 (closed Bugs: fixed)

Opened 2 years ago

Last modified 2 years ago

boost 1.48.0 interprocess does not compile under FreeBSD

Reported by: edouarda14@… Owned by: igaztanaga
Milestone: To Be Determined Component: interprocess
Version: Boost 1.48.0 Severity: Showstopper
Keywords: Cc:

Description

/usr/local/include/boost/interprocess/shared_memory_object.hpp: In member function 'bool boost::interprocess::shared_memory_object::priv_open_or_create(boost::interprocess::ipcdetail::create_enum_t, const char*, boost::interprocess::mode_t, const boost::interprocess::permissions&)': /usr/local/include/boost/interprocess/shared_memory_object.hpp:278:36: error: 'shared_memory_object_ipcdetail' has not been declared /usr/local/include/boost/interprocess/shared_memory_object.hpp: In static member function 'static bool boost::interprocess::shared_memory_object::remove(const char*)': /usr/local/include/boost/interprocess/shared_memory_object.hpp:364:39: error: 'shared_memory_object_ipcdetail' has not been declared

The problem is that the namespace shared_memory_object_ipcdetail does not exist, it's actually shared_memory_object_detail as defined above in shared_memory_object.hpp

I also believe the function name is invalid and that it should be use_filesystem_based_posix, not use_filesistem_based_posix

It's a FreeBSD bug only as this function is only defined in FreeBSD.

Attachments

Change History

comment:1 Changed 2 years ago by igaztanaga

  • Status changed from new to closed
  • Resolution set to fixed

Trunk and Release branch code compiles in FreeBSD (tested in PC-BSD 8 32 bit)

View

Add a comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.