Modify

Ticket #6159 (closed Bugs: fixed)

Opened 2 years ago

Last modified 2 years ago

lexical_cast in 1.48 will not compile on platforms without cwchar

Reported by: justin.viiret@… Owned by: nasonov
Milestone: To Be Determined Component: lexical_cast
Version: Boost 1.48.0 Severity: Problem
Keywords: lexical_cast cwchar wchar_t Cc: antoshkka@…

Description

Boost 1.48 added an include of the <cwchar> header in lexical_cast.hpp, and this breaks compilation on platforms that don't provide it (such as VxWorks?).

It looks like Boost has a macro for handling this case already, so my guess is that this is fixable by just wrapping the include in a check for BOOST_NO_CWCHAR. A patch is attached that works for me.

Attachments

lexical_cast_wchar.patch Download (450 bytes) - added by justin.viiret@… 2 years ago.

Change History

Changed 2 years ago by justin.viiret@…

comment:1 Changed 2 years ago by apolukhin

  • Status changed from new to closed
  • Resolution set to fixed

(In [75812]) Fixes #6159 (compilation on platforms without cwchar)

comment:2 Changed 2 years ago by apolukhin

  • Cc antoshkka@… added

comment:3 Changed 2 years ago by apolukhin

Great thanks!
Fixed in trunk version. As soon as fix cycles through a regression tests it will be merged to release branch.

View

Add a comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.