Modify

Ticket #7155 (closed Feature Requests: fixed)

Opened 21 months ago

Last modified 12 months ago

Graph's GraphML reader mistreats <key for="graphml"> as erroneous

Reported by: alex@… Owned by:
Milestone: To Be Determined Component: graph
Version: Boost 1.51.0 Severity: Optimization
Keywords: BGL, GraphML Cc:

Description

The GraphML specification specifies (see definition of simpleType name="key.for.type" the file graphml-structure.xsd on the GraphML Homepage, which I cannot link due to the spam protection) that

<graphml ...>
  <key for="graphml" id="d0" ... />
  ...

is a valid "for" attribute. The graphml parser in lib/graph/graphml.cpp throws an error:

terminate called after throwing an instance of 'boost::exception_detail::clone_impl<boost::exception_detail::error_info_injector<boost::parse_error> >'
  what():  parse error: Attribute for is not valid: graphml
Aborted

Attachments

graphml.diff Download (712 bytes) - added by alex@… 21 months ago.
Patch

Change History

Changed 21 months ago by alex@…

Patch

comment:1 Changed 21 months ago by jewillco

  • Status changed from new to closed
  • Resolution set to duplicate
  • Component changed from None to graph

This is a duplicate of #7016.

comment:2 Changed 12 months ago by jewillco

  • Resolution changed from duplicate to fixed

(In [83961]) Applied patch from #7155 to add "graphml" as a value for "for"; fixes #7155; fixes #7016

View

Add a comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.