Modify

Ticket #7547 (closed Bugs: fixed)

Opened 18 months ago

Last modified 15 months ago

time_point<system_clock> input version 2 fails to compile

Reported by: viboes Owned by: viboes
Milestone: Boost 1.53.0 Component: chrono
Version: Boost 1.52.0 Severity: Problem
Keywords: Cc:

Description

Unfortunately I had commented the test for time_point<system_clock> input stream and while uncommenting it there is a severe compile error with c++03 standard library as it doesn't provide time_get::get() function

See attached log files for the errors on MacOs? and on Ubuntu.

In addition with c++11 libraries the input doesn't works neither.

Attachments

7547_MacOs.log Download (36.8 KB) - added by viboes 18 months ago.
compile + run fail log for MacOs?
7547_Ubuntu.log Download (13.2 KB) - added by viboes 18 months ago.
Ubuntu log

Change History

Changed 18 months ago by viboes

compile + run fail log for MacOs?

Changed 18 months ago by viboes

Ubuntu log

comment:1 Changed 18 months ago by viboes

Committed in trunk revision [81041] rework the time_point_input test for system_clock to make evident the error.

comment:2 Changed 18 months ago by viboes

  • Status changed from new to assigned

comment:3 Changed 18 months ago by viboes

Committed in trunk [81044] Added internal time_get::get() + fixed some issues in test time_point_input.

comment:4 Changed 18 months ago by viboes

I don't find how to fix this for now. The patch in #7547 disables the specific time_point<system_clock,D> i/o.

comment:5 Changed 18 months ago by viboes

  • Milestone changed from Boost 1.52.0 to To Be Determined

Committed in trunk revision [81045].

comment:6 Changed 18 months ago by viboes

  • Version changed from Boost Release Branch to Boost 1.52.0

Merged from trunk [81056].

comment:7 Changed 18 months ago by viboes

  • Severity changed from Showstopper to Problem

Moved to Problem after disabling the cause.

comment:8 Changed 15 months ago by viboes

  • Milestone changed from To Be Determined to Boost 1.53.0

Rolled back after fixing.

svn diff boost/chrono 
Index: boost/chrono/config.hpp
===================================================================
--- boost/chrono/config.hpp	(revision 82527)
+++ boost/chrono/config.hpp	(working copy)
@@ -28,7 +28,7 @@
 #if ! defined BOOST_CHRONO_PROVIDES_DATE_IO_FOR_SYSTEM_CLOCK_TIME_POINT \
     && ! defined BOOST_CHRONO_DONT_PROVIDE_DATE_IO_FOR_SYSTEM_CLOCK_TIME_POINT
 
-# define BOOST_CHRONO_DONT_PROVIDE_DATE_IO_FOR_SYSTEM_CLOCK_TIME_POINT
+# define BOOST_CHRONO_PROVIDES_DATE_IO_FOR_SYSTEM_CLOCK_TIME_POINT
 
 #endif
 
Index: boost/chrono/io/time_point_io.hpp
===================================================================
--- boost/chrono/io/time_point_io.hpp	(revision 82527)
+++ boost/chrono/io/time_point_io.hpp	(working copy)
@@ -936,6 +936,7 @@
             { '%', 'Y', '-', '%', 'm', '-', '%', 'd', ' ', '%', 'H', ':', '%', 'M', ':' };
             pb = pattern;
             pe = pb + sizeof (pattern) / sizeof(CharT);
+            tm.tm_sec=0;
 #if defined BOOST_CHRONO_USES_INTERNAL_TIME_GET
             const detail::time_get<CharT>& dtg(tg);
             dtg.get(is, 0, is, err, &tm, pb, pe);

comment:9 Changed 15 months ago by viboes

  • Status changed from assigned to closed
  • Resolution set to fixed

Changeset [82612] Chrono: merge [82562][82663].

View

Add a comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.