Modify

Ticket #8197 (closed Bugs: fixed)

Opened 14 months ago

Last modified 5 months ago

range/algorithm conflicts with polygon

Reported by: Stepan Podoskin <stepik-777@…> Owned by: asydorchuk
Milestone: Boost 1.55.0 Component: polygon
Version: Boost 1.53.0 Severity: Problem
Keywords: Cc:

Description

This fails to compile on GCC 4.7.2 (MinGW) but it can be compiled with MSVC 2010.

#include <boost/range/algorithm.hpp>
#include <boost/polygon/polygon.hpp>

Reversing order of includes fixes the problem. (It seems that boost/polygon documentation doesn't mention what headers should be included to use it so I just included polygon.hpp). GCC output attached.

Attachments

gcc-output.txt Download (3.8 KB) - added by Stepan Podoskin <stepik-777@…> 14 months ago.
Output from GCC
8197.patch Download (856 bytes) - added by asydorchuk 9 months ago.

Change History

Changed 14 months ago by Stepan Podoskin <stepik-777@…>

Output from GCC

comment:1 Changed 14 months ago by marshall

Interesting. Compiling with clang (and libc++), I don't get this error.

Just to be clear: I do get the error with gcc 4.7.2

Last edited 14 months ago by marshall (previous) (diff)

comment:2 Changed 14 months ago by viboes

  • Owner set to ljsimons
  • Component changed from None to polygon

comment:3 Changed 14 months ago by asydorchuk

  • Owner changed from ljsimons to asydorchuk

comment:4 Changed 13 months ago by asydorchuk

  • Status changed from new to closed
  • Resolution set to fixed
  • Milestone changed from To Be Determined to Boost 1.54.0

comment:5 Changed 13 months ago by asydorchuk

The issue is fixed on trunk and will go into Boost 1.54 release.

comment:6 Changed 12 months ago by asydorchuk

(In [83918]) [Polygon] Merging from trunk for the upcoming release: 1) Updated Voronoi documentation. 2) Fixed #8026, #8197, #8257.

comment:7 Changed 9 months ago by Stepan Podoskin <stepik-777@…>

  • Status changed from closed to reopened
  • Resolution fixed deleted

I still have this problem with boost 1.54.0 and gcc-4.8.1.

Changed 9 months ago by asydorchuk

comment:8 Changed 9 months ago by asydorchuk

You are right, the fix was not merged successfully from trunk to release branch. I've just merged the fix into the release branch, and it will go live with the next release. Meanwhile, please use the patch (8197.patch) attached to this bug report.

comment:9 Changed 9 months ago by asydorchuk

  • Status changed from reopened to new
  • Milestone changed from Boost 1.54.0 to Boost 1.55.0

comment:10 Changed 5 months ago by asydorchuk

  • Status changed from new to closed
  • Resolution set to fixed
View

Add a comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.