Modify

Ticket #8294 (closed Bugs: fixed)

Opened 14 months ago

Last modified 13 months ago

deque::insert(const_iterator, Itr, Itr) misbehavior

Reported by: expaler Owned by: igaztanaga
Milestone: To Be Determined Component: container
Version: Boost 1.53.0 Severity: Problem
Keywords: Cc:

Description

When the const_iterator argument points to a valid position in the deque that is not past-the-end, the range elements are inserted in the wrong order.

Attachments

deque_insert_range.cpp Download (1.7 KB) - added by expaler 14 months ago.
This test program compares the behavior of boost::container::deque with that of std::deque. Currently it reports errors at lines 40 and 41, after range insertion into the boost::container::deque. Note that using single-element insertion into the boost::container::deque to accomplish the desired result works as intended.

Change History

Changed 14 months ago by expaler

This test program compares the behavior of boost::container::deque with that of std::deque. Currently it reports errors at lines 40 and 41, after range insertion into the boost::container::deque. Note that using single-element insertion into the boost::container::deque to accomplish the desired result works as intended.

comment:1 Changed 13 months ago by igaztanaga

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for the report and the test case. Fixed in revision #83467.

comment:2 Changed 13 months ago by anonymous

Oh, okay. Thanks!

View

Add a comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.