Modify

Ticket #8364 (closed Bugs: fixed)

Opened 13 months ago

Last modified 5 months ago

"Overlay invalid input exception" (1)

Reported by: Volker Schöch <vschoech@…> Owned by: barendgehrels
Milestone: Boost 1.55.0 Component: geometry
Version: Boost 1.52.0 Severity: Problem
Keywords: spikes, polygon, multi polygon, difference Cc:

Description

Please find below some code that triggers "Overlay invalid input exception" (in the last statement of the example). I have a couple of different reproductions, and since I'm not sure if they all share the same root cause, I'm filing them in separate tickets.

As always, my polygon type is oriented counter-clockwise and not closed, my point type is based on int.

This is the data that triggers the exception:

_intPolygon polygon( "MULTIPOLYGON(((1031 1056,3232 1056,3232 2856,1031 2856)))" );
polygon -= _intPolygon( "MULTIPOLYGON(((1032 1458,1032 1212,2136 2328,3234 2220,3234 2412,2136 2646)))" );
polygon -= _intPolygon( "MULTIPOLYGON(((1032 1764,1032 1458,2136 2646,3234 2412,3234 2532,2136 2790)))" );
polygon -= _intPolygon( "MULTIPOLYGON(((1032 2130,1032 1764,2052 2712)),((3234 2580,2558 2690,3234 2532)),((2558 2690,2136 2790,2052 2712,2136 2760)))" );
polygon -= _intPolygon( "MULTIPOLYGON(((1032 2556,1032 2130,1778 2556)),((3234 2580,2136 2760,1778 2556,3234 2556)))" );

This is my code that wraps boost::geometry to implement the operators used above:

template<typename T>
template<typename Geometry>
_TPolygon< T > _TPolygon< T >::operator-(Geometry const& geometry) const
{
       // should not be necessary
       //if( boost::geometry::area(geometry)==0 ) return *this;

       _TPolygon< T > polygonOut;
       boost::geometry::difference(*this, geometry, polygonOut);

       // should not be necessary
       //boost::geometry::correct( polygonOut );

       return polygonOut;
}

template<typename T>
template<typename Geometry>
_TPolygon<T>& _TPolygon< T >::operator-=(Geometry const& geometry)
{
       // boost::geometry::difference cannot operate in-place
       // http://lists.boost.org/geometry/2012/02/1796.php
       *this = *this - geometry;
       return *this;
}

template<typename T>
template<typename Geometry>
_TPolygon< T > _TPolygon< T >::operator^(Geometry const& geometry) const
{
       _TPolygon< T > polygonOut;
       boost::geometry::sym_difference(*this, geometry, polygonOut);

       // should not be necessary
       //boost::geometry::correct( polygonOut );

       return polygonOut;
}

Attachments

Change History

comment:1 Changed 13 months ago by Volker Schöch <vschoech@…>

Note for think-cell: RT 7459

comment:2 Changed 13 months ago by Volker Schöch <vschoech@…>

Our conversation on the geometry mailing list regarding this issue in 1.48.0:  http://lists.boost.org/geometry/2012/02/1871.php

comment:3 Changed 8 months ago by barendgehrels

  • Keywords spikes, added
  • Status changed from new to assigned
  • Milestone changed from To Be Determined to Boost 1.55.0

comment:4 Changed 8 months ago by barendgehrels

  • Status changed from assigned to closed
  • Resolution set to fixed

(In [85451]) [geometry] avoid generation of spikes in overlays, this fixes ticket 8364 and 8365. Added unit tests for these tickets. These changes result in (at about 3 places) changes in the output-number-of-points, this is verified visually

comment:5 Changed 5 months ago by Volker Schöch <vschoech@…>

I can confirm that the problem is no longer reproducible with boost 1.55.0.

View

Add a comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.