Modify

Ticket #8959 (closed Feature Requests: fixed)

Opened 9 months ago

Last modified 7 months ago

BOOST_ASIO_HAS_MOVE should be defined for MSVC 12 and above.

Reported by: smueller@… Owned by: chris_kohlhoff
Milestone: To Be Determined Component: asio
Version: Boost 1.53.0 Severity: Problem
Keywords: Cc:

Description

I needed the ability to perform move construction for basic_io_object instances.

Explicitly defining BOOST_ASIO_HAS_MOVE is the workaround, but it would be good to modify ASIO's config.hpp to handle MSVC 12.

Attachments

config.hpp.patch Download (856 bytes) - added by smueller@… 9 months ago.
MSVC 12 detection to define BOOST_ASIO_HAS_MOVE
config.hpp Download (31.6 KB) - added by smueller@… 7 months ago.
Fixed patch to reflect proper _MSC_VER definitions
config.hpp.2.patch Download (1.1 KB) - added by smueller@… 7 months ago.
Actual fixed patch to reflect MSC_VER changes. (Beware touch screens, early adopters.)

Change History

Changed 9 months ago by smueller@…

MSVC 12 detection to define BOOST_ASIO_HAS_MOVE

comment:1 Changed 9 months ago by smueller@…

This is a duplicate of #8750.

Changed 7 months ago by smueller@…

Fixed patch to reflect proper _MSC_VER definitions

Changed 7 months ago by smueller@…

Actual fixed patch to reflect MSC_VER changes. (Beware touch screens, early adopters.)

comment:2 Changed 7 months ago by chris_kohlhoff

  • Status changed from new to closed
  • Resolution set to fixed

Fixed on trunk in [85766]. Merged to release in [85838]

View

Add a comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.