Modify

Opened 7 years ago

Closed 7 years ago

#4630 closed Bugs (duplicate)

[filesystem] Wave regression test failure on Mingw

Reported by: rwebb <richard.webb@…> Owned by: Beman Dawes
Milestone: Boost 1.45.0 Component: filesystem
Version: Boost Development Trunk Severity: Problem
Keywords: Cc:

Description

One of the Wave regression tests is failing On Mingw with the error

../boost/filesystem/v2/operations.hpp:1191:24: error: 'boost::filesystem2::create_hard_link' has not been declared

(see http://tinyurl.com/3x3y9jj).

Looks like the "using filesystem2::create_hard_link;" on line 1191 of operations.hpp needs to be guarded with an

#if !defined(BOOST_WINDOWS_API) || defined(BOOST_FS_HARD_LINK)

as the declaration of create_hard_link iteself is.

Attachments (0)

Change History (2)

comment:1 Changed 7 years ago by jim@…

This change is also required for a MinGW-32 project just upgraded from boost 1.38. Thanks for doing the research.

comment:2 Changed 7 years ago by Beman Dawes

Resolution: duplicate
Status: newclosed

Fixed by changeset 65371. See #4487.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Beman Dawes.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.