Opened 5 years ago

Closed 5 years ago

#9712 closed Bugs (fixed)

Documentation errors

Reported by: denalepa1@… Owned by: Paul A. Bristow
Milestone: Boost 1.56.0 Component: math
Version: Boost 1.55.0 Severity: Problem
Keywords: Cc:


In Version 1.55.0 DOCUMENTATION there are two "typographical" errors. MATH/CONSTANTS documentation, the Table of math constants contains two errors:

  1. The value of pi_minus_three is listed as 1.41593

it should be 0.141593

-=-=- -=-=-

  1. The constant pow23_four_minus_pi is represented as 4(2/3) - π

It should be (4-π)3/2

2a. Note that 2/3 is NOT 3/2.

I assume that the constant is badly named and its name is inconsistent with its actual value. This is a deeper problem that the creators may wish to address.

Change History (7)

comment:1 Changed 5 years ago by Steven Watanabe

Component: Documentationmath
Owner: changed from Matias Capeletto to John Maddock

I think math is the right component, but a link to the page containing the problem would be helpful.

comment:2 Changed 5 years ago by John Maddock

Owner: changed from John Maddock to Paul A. Bristow

Paul, can I get you to check these out? Thanks!

comment:3 Changed 5 years ago by Paul A. Bristow

Sorry for delay in response. Thanks for reporting this mistake, and not really just in the documentation :-(

Do you have a view of which constant is useful. I can't find where the constant called pow23_four_minus_pi is used.

It clearly should be the correct name/value combination.

Is either or both useful - especially to you?




(or both)

comment:4 Changed 5 years ago by John Maddock

A quick grep shows it was used in the Rayleigh distribution at one point, but is commented out. Maybe we should just remove it - I doubt it has much general use?

comment:5 Changed 5 years ago by John Maddock

On second thoughts, maybe

template <class RealType, class Policy>
inline RealType kurtosis(const rayleigh_distribution<RealType, Policy>& /*dist*/)

Should really use the constant? albeit we need to check both the name and the value to see which is correct ;)

comment:6 Changed 5 years ago by Paul A. Bristow

The constant pow23_four_minus_pi does not seem generally useful and is not necessary for Rayleigh skewness or kurtosis.

So the constant has been removed and an explicit calculation used for the kurtosis excess(and skewness). This agrees with the constant calculated using NTL previously.

comment:7 Changed 5 years ago by Paul A. Bristow

Milestone: To Be DeterminedBoost 1.56.0
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.