Modify

Ticket #6130 (closed Bugs: wontfix)

Opened 2 years ago

Last modified 20 months ago

condition_variable::timed_wait wakes up too early

Reported by: Gennady Proskurin <gpr@…> Owned by: anthonyw
Milestone: To Be Determined Component: thread
Version: Boost 1.47.0 Severity: Problem
Keywords: Cc:

Description

condition_variable::timed_wait sometimes returns with timeout too early, 1 second before specified time. Test program attached.

Reliably reproduces on the following system: System: openSUSE 11.4, Linux 2.6.37.6-0.7-desktop #1 SMP PREEMPT 2011-07-21 02:17:24 +0200 i686 i686 i386 GNU/Linux

Attachments

cvt.cc Download (571 bytes) - added by Gennady Proskurin <gpr@…> 2 years ago.
cvt1.c Download (1.0 KB) - added by Gennady Proskurin <gpr@…> 2 years ago.

Change History

Changed 2 years ago by Gennady Proskurin <gpr@…>

comment:1 Changed 2 years ago by viboes

  • Cc viboes added

Unfortunately I'm unable to reproduce it. Please could you attach a trace when the problem occurs?

Changed 2 years ago by Gennady Proskurin <gpr@…>

comment:2 Changed 2 years ago by Gennady Proskurin <gpr@…>

It seems that it is not a boost bug, the same C program (cvt1.c), which uses plain posix api (pthread_cond_timedwait) triggers the same assert. So, this seems to be a bug in OS, I will try to post it to openSUSE team.
I think, this bug can be closed.

comment:3 Changed 2 years ago by Gennady Proskurin <gpr@…>

I filled bugreport for openSUSE:  https://bugzilla.novell.com/show_bug.cgi?id=734709

comment:4 Changed 2 years ago by viboes

  • Cc viboes removed
  • Status changed from new to closed
  • Resolution set to wontfix

Please, let us know what is the result of this bugreport.

comment:5 Changed 2 years ago by viboes

  • Resolution changed from wontfix to fixed

(In [78285]) Thread: try to fix ticket 6130 for linux systems

comment:6 Changed 20 months ago by viboes

  • Status changed from closed to reopened
  • Resolution fixed deleted

comment:7 Changed 20 months ago by viboes

  • Status changed from reopened to closed
  • Resolution set to wontfix

The change in [78285] has been rolled back, as it was not a good solution. The library can not provide a fix to the OS bug.

View

Add a comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.