Modify

Opened 6 years ago

Closed 5 years ago

#6130 closed Bugs (wontfix)

condition_variable::timed_wait wakes up too early

Reported by: Gennady Proskurin <gpr@…> Owned by: anthonyw
Milestone: To Be Determined Component: thread
Version: Boost 1.47.0 Severity: Problem
Keywords: Cc:

Description

condition_variable::timed_wait sometimes returns with timeout too early, 1 second before specified time. Test program attached.

Reliably reproduces on the following system: System: openSUSE 11.4, Linux 2.6.37.6-0.7-desktop #1 SMP PREEMPT 2011-07-21 02:17:24 +0200 i686 i686 i386 GNU/Linux

Attachments (2)

cvt.cc (571 bytes) - added by Gennady Proskurin <gpr@…> 6 years ago.
cvt1.c (1.0 KB) - added by Gennady Proskurin <gpr@…> 6 years ago.

Download all attachments as: .zip

Change History (9)

Changed 6 years ago by Gennady Proskurin <gpr@…>

comment:1 Changed 6 years ago by viboes

  • Cc viboes added

Unfortunately I'm unable to reproduce it. Please could you attach a trace when the problem occurs?

Changed 6 years ago by Gennady Proskurin <gpr@…>

comment:2 Changed 6 years ago by Gennady Proskurin <gpr@…>

It seems that it is not a boost bug, the same C program (cvt1.c), which uses plain posix api (pthread_cond_timedwait) triggers the same assert. So, this seems to be a bug in OS, I will try to post it to openSUSE team.
I think, this bug can be closed.

comment:3 Changed 6 years ago by Gennady Proskurin <gpr@…>

comment:4 Changed 6 years ago by viboes

  • Cc viboes removed
  • Resolution set to wontfix
  • Status changed from new to closed

Please, let us know what is the result of this bugreport.

comment:5 Changed 5 years ago by viboes

  • Resolution changed from wontfix to fixed

(In [78285]) Thread: try to fix ticket 6130 for linux systems

comment:6 Changed 5 years ago by viboes

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:7 Changed 5 years ago by viboes

  • Resolution set to wontfix
  • Status changed from reopened to closed

The change in [78285] has been rolled back, as it was not a good solution. The library can not provide a fix to the OS bug.

Add Comment

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain anthonyw.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.