Opened 11 years ago

Last modified 23 months ago

#1049 new Patches

Getting mpl/has_xxx.hpp to compile on AIX

Reported by: troyer@… Owned by: Aleksey Gurtovoy
Milestone: To Be Determined Component: mpl
Version: Severity: Problem
Keywords: Cc:

Description

Moving the class gcc_3_2_wknd out of the enclosing class scope into the namespace scope makes thius compile on AIX.

The attached patch was for 1.33.1

Attachments (1)

patch.txt (1.4 KB) - added by troyer@… 11 years ago.
patch for mpl/has_xxx.hpp

Download all attachments as: .zip

Change History (3)

Changed 11 years ago by troyer@…

Attachment: patch.txt added

patch for mpl/has_xxx.hpp

comment:1 Changed 11 years ago by Dave Abrahams

Owner: set to Aleksey Gurtovoy

comment:2 Changed 23 months ago by Kohei Takahashi

GCC 3.2 is quite old and not supported now. So, isn't this wontfix?

Note: See TracTickets for help on using tickets.