Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#10652 closed Bugs (invalid)

[fusion] boost/fusion/iterator/iterator_adapter.hpp problem

Reported by: John Fletcher <J.P.Fletcher@…> Owned by: Joel de Guzman
Milestone: To Be Determined Component: fusion
Version: Boost 1.56.0 Severity: Problem
Keywords: Cc:

Description

boost/fusion/iterator/iterator_adapter.hpp will not compile unless the following headers are available before it is included:

boost/fusion/iterator/advance.hpp

boost/fusion/iterator/deref.hpp

boost/fusion/iterator/distance.hpp

boost/fusion/iterator/value_of.hpp

This could be overcome by including them within it.

Change History (5)

comment:1 Changed 4 years ago by Kohei Takahashi <flast@…>

I think this is dup of #8457 .

comment:2 Changed 4 years ago by Joel de Guzman

Resolution: invalid
Status: newclosed

comment:3 Changed 4 years ago by John Fletcher <J.P.Fletcher@…>

I don't understand marking this 'invalid'. It needs fixing.

comment:4 Changed 4 years ago by Joel de Guzman

Isn't this a duplicate of #8457 as Kohei noted above? If so, one ticket will do.

comment:5 Changed 4 years ago by John Fletcher <J.P.Fletcher@…>

O.K. Are you clear on what needs to be done?

Note: See TracTickets for help on using tickets.