Opened 4 years ago

Closed 4 years ago

#10790 closed Bugs (fixed)

long long errors from container

Reported by: John Maddock Owned by: Ion Gaztañaga
Milestone: To Be Determined Component: container
Version: Boost 1.57.0 Severity: Problem
Keywords: Cc:

Description

There are some failures caused by Boost.Container using long long: http://www.boost.org/development/tests/develop/developer/output/FBSD-64%20jc-bell-boost-bin-v2-libs-regex-test-regex_regress_threaded-test-gcc-4-2-1-debug-threading-multi.html

The issue is that the compiler does support use of long long, but only under strict circumstances, the workaround is to use boost::long_long_type and boost::ulong_long_type defined in boost/config.hpp as these typedefs suppress the warnings which later lead to errors. Hope this makes sense!

Thanks, John.

Change History (2)

comment:1 Changed 4 years ago by Michel Morin

Component: Nonecontainer
Owner: set to Ion Gaztañaga

comment:2 Changed 4 years ago by Ion Gaztañaga

Resolution: fixed
Status: newclosed

Thanks, I didn't know about long_long_type.

Commit in trunk SHA-1: 1d38ecfd1025ef1e4f1312a0300630580aeb5fd7

  • Fixed #10790 (Trac): long long errors from container
Note: See TracTickets for help on using tickets.