Modify

Opened 3 years ago

Closed 3 weeks ago

#11451 closed Feature Requests (duplicate)

[feature] Make odeint works with std::tuple and boost::units

Reported by: pierre blavy <blavy@…> Owned by: karsten
Milestone: To Be Determined Component: odeint
Version: Boost 1.57.0 Severity: Not Applicable
Keywords: odeint, units Cc:

Description

Dear developper, here is a patch that

  • make odeint work with std::tuple.
  • make odeint work with boost::units tuple.
  • patch std::numeric limits for boost::units::qunatity, by delegating limits to the underlying type. That's important as, without this patch, std::numeric_limits silently return stupid values with boost::units::quantity.

I'm not a boost developper and I realy had trouble to understand the documentation, so I'm not sure that the things I've done are correct or doens't break an other part of boost, so please, carefully review this code. I post it in the hope that it will be usefull for you.

Attachments (0)

Change History (2)

comment:1 Changed 2 years ago by viboes

Component: Noneodeint
Owner: set to karsten

comment:2 Changed 3 weeks ago by Jürgen Hunold

Resolution: duplicate
Status: newclosed

Duplicate of #11452

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain karsten.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.