Opened 11 years ago

Closed 5 years ago

#1205 closed Feature Requests (duplicate)

Quickbook getting started

Reported by: Joel de Guzman Owned by: Joel de Guzman
Milestone: To Be Determined Component: quickbook
Version: Boost 1.34.1 Severity: Problem
Keywords: Cc:

Description

From John:

I've just read through the quick book docs with a view to using quickbook for a type traits docs rewrite, and have some questions:

  • There's no mention of how to build a quickbook document, what goes in the jamfile etc.

(Joel: trimmed down the remaining two items; outdated)

Change History (2)

comment:1 Changed 9 years ago by mloskot <mateusz@…>

I suppose a simple Jamfile sample could do the job:

# Configuration of documentation build for 'mylib' as a part of Boost C++ tree.

# specify project id for mylib documentation
project boost/libs/mylib/doc ;

# import Quickbook
import boostbook : boostbook ;
using quickbook ;

# specify location for custom images
path-constant images_location : html ;

# define target
boostbook quickbook
    :
        mylib.qbk
    :
        <xsl:param>boost.root=../../../..
        <xsl:param>boost.libraries=../../../libraries.htm
        <xsl:param>html.stylesheet=../../../../doc/html/boostbook.css
        <xsl:param>chunk.section.depth=4
        <xsl:param>chunk.first.sections=1
        <xsl:param>toc.section.depth=3
        <xsl:param>toc.max.depth=3
        <xsl:param>generate.section.toc.level=4
        <format>pdf:<xsl:param>boost.url.prefix=http://www.boost.org/doc/libs/release/libs/mylib/doc/html
        <format>pdf:<xsl:param>img.src.path=$(images_location)/
    ;

Assuming it is boost/libs/mylib/doc/Jamfile, enter boost/libs/mylib/doc directory and issue bjam command and you should similar output:

$ bjam
...found 28 targets...
...updating 6 targets...
common.mkdir bin
common.mkdir bin/gcc-4.4.1
common.mkdir bin/gcc-4.4.1/debug
quickbook.quickbook-to-boostbook bin/gcc-4.4.1/debug/mylib.xml
Generating Output File: bin/gcc-4.4.1/debug/mylib.xml
xslt-xsltproc bin/gcc-4.4.1/debug/mylib.docbook
xslt-xsltproc-dir html/mylib_HTML.manifest
Writing mylib_HTML.manifest
...updated 6 targets...

comment:2 Changed 5 years ago by Daniel James

Resolution: duplicate
Status: newclosed

I'm going to mark this as a duplicate of #5985. Even though that's later as it's a bit more broad.

Note: See TracTickets for help on using tickets.