Opened 2 years ago

Last modified 2 years ago

#12238 new Bugs

Boost fails to compile using OpenSSL 1.1.0

Reported by: noloader@… Owned by: chris_kohlhoff
Milestone: To Be Determined Component: asio
Version: Boost 1.61.0 Severity: Problem
Keywords: openssl 1.1.0 Cc: raad@…, jack@…

Description

Boost 1.61 cannot compile when using OpenSSL 1.1.0. Also see http://stackoverflow.com/q/37517730.

My apologies if this has been reported. A quick search appears to show there are no reports (https://svn.boost.org/trac/boost/search?q=%22openssl+1.1.0%22).

Change History (10)

comment:1 Changed 2 years ago by noloader@…

Summary: Boost fails to compil under OpenSSL 1.1.0Boost fails to compile using OpenSSL 1.1.0

comment:2 Changed 2 years ago by John Maddock

Component: Noneasio
Owner: set to chris_kohlhoff

comment:3 Changed 2 years ago by anonymous

Same issue here. To be fair 1.1.0 just made official release 11 days ago.

comment:4 Changed 2 years ago by anonymous

yes, and we are trying to get openssl 1.1 in the next Debian stable, this bug will keep a lot of the archive unbuildable and out of the next stable.

comment:6 Changed 2 years ago by raad@…

Cc: raad@… added

comment:8 Changed 2 years ago by jack@…

I am using the above two linked patches to upgrade OpenSSL in Zcash to 1.1.0a. I have hand-ported them to Boost 1.62.0(.beta.2), but they should probably be properly rebased.

comment:9 Changed 2 years ago by jack@…

Cc: jack@… added

comment:10 Changed 2 years ago by jack@…

Looks like Boost 1.62 includes the above patches to ASIO, and thus compiles with OpenSSL 1.1.0.

Note: See TracTickets for help on using tickets.