Modify

Opened 9 years ago

Closed 9 years ago

#2570 closed Bugs (fixed)

boost::interprocess::message_queue::timed_send and timed_receive bug

Reported by: Tony Astolfi <aastolfi@…> Owned by: Ion Gaztañaga
Milestone: Boost 1.38.0 Component: interprocess
Version: Boost 1.37.0 Severity: Showstopper
Keywords: Cc:

Description

In boost::interprocess::message_queue, the timed_send and timed_receive methods may return true without actually performing the send or receive operation.

The problem lies in boost/interprocess/ipc/message_queue.hpp, in the logic that handles blocking behavior for these two methods. Both implementations have the same form:

if (<operation-would-block>) {

switch(block){

... case timed : do{

if(!<condition-variable>.timed_wait(lock, abs_time))

return !<operation-would-block>;

} while (<operation-would-block>); break; ...

}

}

The problem is that when timed_wait returns false, it might be possible to complete the operation without blocking (i.e. there might be something in the queue in the case of receive, or the queue might not be full in the case of send). Therefore, in rare cases, timed_send/timed_receive return true, without having actually done any work.

My proposed fix is to change the timed case to:

do{

if(!<condition-variable>.timed_wait(lock, abs_time)) {

if(<operation-would-block>) {

return false;

} break;

}

} while (<operation-would-block>);

After I apply this change to my own boost install, the problem disappears.

I observed this bug on Linux (some Debian 4 flavor, 32-bit)

Attachments (0)

Change History (3)

comment:1 Changed 9 years ago by Ion Gaztañaga

Resolution: fixed
Status: newclosed

Fixed in revision 50146

comment:2 in reply to:  1 Changed 9 years ago by Tony Astolfi <aastolfi@…>

Resolution: fixed
Status: closedreopened

Replying to igaztanaga:

Fixed in revision 50146

Fix for timed_send looks good.

Fix for timed_receive is missing curly-braces around the outer if body.

comment:3 Changed 9 years ago by Ion Gaztañaga

Resolution: fixed
Status: reopenedclosed

Sorry! Fixed in revision 50194.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Ion Gaztañaga.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.