Modify

Opened 9 years ago

Closed 7 years ago

#2611 closed Bugs (fixed)

Unordered containers not usable when EBO is not supported

Reported by: Andrey Semashev Owned by: Ion Gaztañaga
Milestone: Boost 1.45.0 Component: intrusive
Version: Boost 1.37.0 Severity: Problem
Keywords: EBO intrusive stateless Cc:

Description

If EBO (Empty Base Optimization) is not supported by the compiler unordered containers cannot be used. That is, at least find functions don't compile because they internally use s_iterator_to on the slist bucket, which contains a check that its value_traits is stateless.

The root of the problem is in this check implementation and in the detail::is_empty_class implementation in particular. If EBO is not supported, the predicate will always return false.

I've encountered the problem with unordered containers, but I suspect other containers might be affected, too.

The proposed solution is to specialize is_empty_class template on the library-provided traits, so that it returns in the correct result. Or remove the stateless checks altogether. This should be noted in the docs (if the specialization approach is chosen, it should be said what template users have to specialize to make things work with their custom value traits).

Attachments (0)

Change History (1)

comment:1 Changed 7 years ago by Ion Gaztañaga

Milestone: Boost 1.38.0Boost-1.45.0
Resolution: fixed
Status: newclosed

For compliant compilers now is_stateful_value_traits tries to detect that all needed functions are static.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Ion Gaztañaga.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.