Modify

Opened 8 years ago

Closed 8 years ago

#2712 closed Bugs (fixed)

Quickbook uses article title rather than article id for links

Reported by: pbristow Owned by: danieljames
Milestone: Boost 1.41.0 Component: quickbook
Version: Boost 1.37.0 Severity: Cosmetic
Keywords: quickbook link article id title Cc:

Description

This Quickbook with a long title but short id

[article Title of test of quickbook

[quickbook 1.4] [id quick_test] [authors [Bristow, Paul A.]] [copyright 2009 Paul A. Bristow] [license

Distributed under the Boost Software License, Version 1.0. (See accompanying file LICENSE_1_0.txt or copy at [@http://www.boost.org/LICENSE_1_0.txt])

] [source-mode c++] [purpose test of links that include title or article id.]

]

I expect that link would start with article id: quick_test [/ And NOT the converted article title "Title of test of quickbook" [def test_link [link quick_test.my_section1 Section One]]

[section: my_section1 This is my 1st section]

Section 1 ...

[endsect] my_section1 This is my 1st section

[/ test_q.qbk

Copyright 2009 Paul A. Bristow. Distributed under the Boost Software License, Version 1.0. (See accompanying file LICENSE_1_0.txt or copy at http://www.boost.org/LICENSE_1_0.txt).

]

produces this output

Note the

<section id="quick_test._my_section1_this_is_my_1st_section">

uses the converted title, and not the article id, as I expected.

<?xml version="1.0" encoding="UTF-8"?> <!DOCTYPE library PUBLIC "-BoostDTD BoostBook? XML V1.0EN" "http://www.boost.org/tools/boostbook/dtd/boostbook.dtd"> <article id="quick_test" name="Title of test of quickbook" dirname="quick_test" last-revision="$Date: 2009/02/02 12:46:50 $"

xmlns:xi="http://www.w3.org/2001/XInclude">

<articleinfo>

<authorgroup> <author>

<firstname>Paul A.</firstname> <surname>Bristow</surname>

</author> </authorgroup> <copyright>

<year>2009</year> <holder>Paul A. Bristow</holder>

</copyright> <legalnotice>

<para>

Distributed under the Boost Software License, Version 1.0. (See accompanying file LICENSE_1_0.txt or copy at <ulink url="http://www.boost.org/LICENSE_1_0.txt">http://www.boost.org/LICENSE_1_0.txt</ulink>)

</para>

</legalnotice> <articlepurpose>

test of links that include title or article id.

</articlepurpose>

</articleinfo> <title>Title of test of quickbook</title> <para>

[/ And NOT the converted article title &quot;Title of test of quickbook&quot;

</para> <section id="quick_test._my_section1_this_is_my_1st_section">

<title><link linkend="quick_test._my_section1_this_is_my_1st_section"> my_section1 This is my 1st section</link></title> <para>

Section 1 ...

</para>

</section>

</article>

Attachments (0)

Change History (9)

comment:1 Changed 8 years ago by danieljames

  • Component changed from None to quickbook
  • Status changed from new to assigned

OK, I think the problem is that you've got a space after the colon in your section:

[section: my_section1 This is my 1st section]

should be:

[section:my_section1 This is my 1st section]

which should work as you expect. It's not the article id that's wrong it's the section id.

So, it's not exactly a bug, but quickbook should behave better in this circumstance - either by ignoring the space and using the section id that you were expecting, or a warning or error. The warning is the only non-breaking option, but one of the other two could be used for quickbook 1.5.

comment:2 Changed 8 years ago by danieljames

  • Milestone changed from Boost 1.38.0 to Boost 1.39.0

comment:3 Changed 8 years ago by danieljames

  • Milestone changed from Boost 1.39.0 to To Be Determined

comment:4 Changed 8 years ago by danieljames

  • Milestone changed from To Be Determined to Boost 1.40.0

comment:5 Changed 8 years ago by danieljames

(In [53734]) Ignore spaces after 'section:' for quickbook 1.5+ Refs #2712

And warn when section id is empty after colon.

comment:6 Changed 8 years ago by danieljames

  • Milestone changed from Boost 1.40.0 to Boost 1.41.0

comment:7 Changed 8 years ago by danieljames

(In [55911]) Ignore spaces after 'section:' for quickbook 1.5+ Refs #2712

And warn when section id is empty after colon.

comment:8 Changed 8 years ago by danieljames

(In [56752]) Merge quickbook 1.5 from trunk.

Merged revisions 55905-55917,56077,56715,56717-56719 via svnmerge from https://svn.boost.org/svn/boost/trunk

........

r55905 | danieljames | 2009-08-31 12:36:13 +0100 (Mon, 31 Aug 2009) | 1 line

Update quickbook version number.

........

r55906 | danieljames | 2009-08-31 12:36:23 +0100 (Mon, 31 Aug 2009) | 4 lines

Create entry for 1.5 in the change log.

Starting it of with some of the changes that have been made to quickbook since 1.4 - considering the first 1.4 release as the proper 1.4 release.

........

r55907 | danieljames | 2009-08-31 12:36:34 +0100 (Mon, 31 Aug 2009) | 3 lines

Wrap the template info in a struct.

So that I can add extra scoping info.

........

r55908 | danieljames | 2009-08-31 12:36:47 +0100 (Mon, 31 Aug 2009) | 1 line

Implement static/lexical scoping for 1.5. Refs #2034.

........

r55909 | danieljames | 2009-08-31 12:37:04 +0100 (Mon, 31 Aug 2009) | 1 line

In quickbook 1.5 don't mix '..' and whitespace seperators for template arguments. Refs #1174

........

r55910 | danieljames | 2009-08-31 12:37:17 +0100 (Mon, 31 Aug 2009) | 2 lines

Put the quickbook version numbers in a single header, along with convenience functions for using them in spirit grammars.

........

r55911 | danieljames | 2009-08-31 12:37:32 +0100 (Mon, 31 Aug 2009) | 3 lines

Ignore spaces after 'section:' for quickbook 1.5+ Refs #2712

And warn when section id is empty after colon.

........

r55912 | danieljames | 2009-08-31 12:37:48 +0100 (Mon, 31 Aug 2009) | 1 line

Introduce temporary id variable.

........

r55913 | danieljames | 2009-08-31 12:37:59 +0100 (Mon, 31 Aug 2009) | 1 line

Table ids. Refs #1194.

........

r55914 | danieljames | 2009-08-31 12:38:11 +0100 (Mon, 31 Aug 2009) | 1 line

Separate out the current version of the template argument parser, as I want to create a new one for 1.5

........

r55915 | danieljames | 2009-08-31 12:38:20 +0100 (Mon, 31 Aug 2009) | 1 line

Don't use seperators that are in brackets, or are escaped. Refs #2036.

........

r55916 | danieljames | 2009-08-31 12:38:33 +0100 (Mon, 31 Aug 2009) | 1 line

Add missing table tests.

........

r55917 | danieljames | 2009-08-31 12:38:47 +0100 (Mon, 31 Aug 2009) | 1 line

Support image attributes. Refs #1157.

........

r56077 | djowel | 2009-09-07 02:35:24 +0100 (Mon, 07 Sep 2009) | 1 line

fix for msvc

........

r56715 | danieljames | 2009-10-11 17:18:04 +0100 (Sun, 11 Oct 2009) | 1 line

Use qualified ids in tables, and fix a bug generating ids when there isn't a section.

........

r56717 | danieljames | 2009-10-11 19:21:11 +0100 (Sun, 11 Oct 2009) | 1 line

Document the simplified quickbook 1.5 argument separators.

........

r56718 | danieljames | 2009-10-11 19:21:32 +0100 (Sun, 11 Oct 2009) | 1 line

Use quickbook 1.5 in the document block example.

........

r56719 | danieljames | 2009-10-11 19:21:48 +0100 (Sun, 11 Oct 2009) | 1 line

Add table ids to the documentation.

........

comment:9 Changed 8 years ago by danieljames

  • Resolution set to fixed
  • Status changed from assigned to closed

Add Comment

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain danieljames.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.