Modify

Opened 8 years ago

Closed 8 years ago

#2992 closed Bugs (fixed)

Linker error using 1.39 with vc80

Reported by: Volker Wippel <Volker.Wippel@…> Owned by: igaztanaga
Milestone: Boost 1.39.0 Component: interprocess
Version: Boost 1.38.0 Severity: Showstopper
Keywords: linker error Cc:

Description

Using shared memory in more than one cpp file gives linker warnings and errors. It looks like the compiler ignores the inline of huge functions in interprocess\detail\win32_api.hpp like get_file_name_from_handle_function or unlink_file. These are the only functions which the linker does not like.

Attachments (0)

Change History (3)

comment:1 Changed 8 years ago by Volker Wippel <Volker.Wippel@…>

  • Component changed from None to interprocess
  • Keywords linker error added
  • Owner set to igaztanaga
  • Severity changed from Problem to Showstopper

comment:2 Changed 8 years ago by steven_watanabe

The problem is the local classes. See #3090, which I've closed as a duplicate.

comment:3 Changed 8 years ago by igaztanaga

  • Resolution set to fixed
  • Status changed from new to closed

Fixed for Boost 1.40

Add Comment

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain igaztanaga.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.