Opened 10 years ago

Closed 10 years ago

#3155 closed Patches (fixed)

Modified BGL iterator macros

Reported by: tkeitt@… Owned by: Douglas Gregor
Milestone: Boost 1.40.0 Component: graph
Version: Boost 1.39.0 Severity: Problem
Keywords: graph, iterator Cc:

Description

The current graph iterator macros split iterator comparisons across calls to vertices, edges, et al. I have modified the macros to include only a single call to vertices, edges, et al. The behavior of the code remains the same. All regression tests passed after the change.

Attachments (2)

bgl.diff (12.0 KB) - added by tkeitt@… 10 years ago.
svn diff
bgl.2.diff (11.3 KB) - added by tkeitt@… 10 years ago.
patch for iterator_macros.hpp (fixed some formatting)

Download all attachments as: .zip

Change History (4)

Changed 10 years ago by tkeitt@…

Attachment: bgl.diff added

svn diff

comment:1 Changed 10 years ago by tkeitt@…

Oops. Looks like I messed up the formatting in the comment. I'll fix and resend.

Changed 10 years ago by tkeitt@…

Attachment: bgl.2.diff added

patch for iterator_macros.hpp (fixed some formatting)

comment:2 Changed 10 years ago by Jeremiah Willcock

Resolution: fixed
Status: newclosed

(In [53778]) Fixed issues from ticket 3155; fixes #3155, refs #3134

Note: See TracTickets for help on using tickets.