Modify

Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#3425 closed Bugs (fixed)

ICU_LINK doesn't work

Reported by: Andrey Semashev Owned by: John Maddock
Milestone: Boost 1.41.0 Component: regex
Version: Boost 1.40.0 Severity: Problem
Keywords: icu Cc:

Description

I'm trying to compile Boost.Regex with ICU 3.4 and MSVC 7.1. The ICU library in my case has a nonstandard directory layout like this:

  icu
   |
   |->include
   |   |
   |   |->layout
   |   |->unicode
   |
   |->win32
       |
       |->lib

So the library binaries are in icu/win32/lib instead of the standard icu/lib. I tried to use ICU_LINK environment variable, like bjam suggests (note, I use Cygwin to build the library):

export HAVE_ICU=1
export ICU_PATH="$PATH_TO_ICU/icu"
export ICU_LINK="/LIBPATH:$PATH_TO_ICU/icu/win32/lib icuuc.lib icuin.lib icudt.lib"

However, it seems this variable has no effect, the parameters in ICU_LINK are not seen in the linker command line.

What I eventually came up with was to explicitly specify $ICU_LINK in linkflags for bjam when building Boost.Regex.

Attachments (1)

Jamfile.v2.patch (330 bytes) - added by Andrey Semashev 8 years ago.
The patch fixes the Jamfile so that it passes ICU_LINK flags to the linker

Download all attachments as: .zip

Change History (2)

Changed 8 years ago by Andrey Semashev

Attachment: Jamfile.v2.patch added

The patch fixes the Jamfile so that it passes ICU_LINK flags to the linker

comment:1 Changed 8 years ago by John Maddock

Resolution: fixed
Status: newclosed

(In [57252]) Fixes #3425.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain John Maddock.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.