Modify

Opened 7 years ago

Closed 5 years ago

#4711 closed Bugs (fixed)

Must use implementation details to return move-only types

Reported by: Dave Abrahams Owned by: viboes
Milestone: Boost 1.50.0 Component: thread
Version: Boost 1.44.0 Severity: Problem
Keywords: move Cc: viboes

Description

I can't directly return a move-only type and must instead return boost::detail::thread_move_t<…>. That should be improved/fixed. It is possible to write move emulation that allows them to be returned directly.

Attachments (0)

Change History (9)

comment:1 Changed 7 years ago by viboes

Type: BugsSupport Requests

I have moved it to support until the issue is clarified. Please could you be more explicit?

comment:2 Changed 7 years ago by anonymous

Take any move-only type from the library and try to return it from a function, using only documented APIs. For me it fails unless I use something from namespace detail. It's been a while, so I don't have the code handy, but is this clear enough?

comment:3 Changed 7 years ago by viboes

Cc: viboes added

Please could you provide a short test? This is a way to help the Boost community.

comment:4 in reply to:  3 Changed 7 years ago by Dave Abrahams

Replying to viboes:

Please could you provide a short test? This is a way to help the Boost community.

Not that I often pass up an opportunity to help the Boost community, but I don't think I'll have time to build one anytime soon. That said, you have all the info here that you should need to write one yourself.

comment:5 Changed 6 years ago by viboes

Type: Support RequestsBugs

comment:6 Changed 6 years ago by viboes

Keywords: move added

There is an action point to use Boost.Move. Could we consider this as a duplicate of #6194 Adapt to Boost.Move.

Last edited 6 years ago by viboes (previous) (diff)

comment:7 Changed 6 years ago by viboes

Owner: changed from Anthony Williams to viboes
Status: newassigned

comment:8 Changed 6 years ago by viboes

Milestone: To Be DeterminedBoost 1.49.0

comment:9 Changed 5 years ago by viboes

Milestone: Boost 1.49.0Boost 1.50.0
Resolution: fixed
Status: assignedclosed

Documentation has been added for the new Boost.Move move semantics and the old one.

Committed in release branch at [78543]

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain viboes.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.