Modify

Opened 7 years ago

Closed 7 years ago

#4719 closed Bugs (duplicate)

date::day_of_week documentation is unhelpful

Reported by: russell.silva@… Owned by: Matias Capeletto
Milestone: To Be Determined Component: Documentation
Version: Boost 1.44.0 Severity: Problem
Keywords: Cc:

Description

The Gregorian date documentation for the day_of_week method is unhelpful. It's not clear what the return type of the method is; it's not immediately obvious what a greg_day_of_week is. The example does not help, since it does not use the method at all. It turns out that the method returns an integer, but there is no documentation as to which day corresponds to which integer return value.

http://www.boost.org/doc/libs/1_43_0/doc/html/date_time/gregorian.html#date_time.gregorian.date_class

Attachments (0)

Change History (1)

comment:1 Changed 7 years ago by Marshall Clow

Resolution: duplicate
Status: newclosed

Duplicate of #4718

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Matias Capeletto.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.