Modify

Opened 6 years ago

Closed 6 years ago

#5100 closed Bugs (fixed)

runtime_error locale::facet::_S_create_c_locale name not valid

Reported by: Rui Pedro Fernandes <ruipfernandes@…> Owned by: bemandawes
Milestone: Boost 1.48.0 Component: filesystem
Version: Boost 1.45.0 Severity: Problem
Keywords: Cc:

Description

static initialization in filesystem v3 at path.cpp:98 leads to the runtime error that gives title to the ticket.

I know this is a problem with libstdc++ (c_locale.cc contains this comment: "Currently, the generic model only supports the "C" locale."). However, I'm using default filesystem v2 and thus this should not be an issue to me (as it wasn't when I was using boost_1_41).

Attachments (0)

Change History (3)

comment:1 Changed 6 years ago by Sam Morris <sam@…>

Duplicate of #4688?

comment:2 Changed 6 years ago by bemandawes

  • Milestone changed from To Be Determined to Boost 1.48.0
  • Status changed from new to assigned

4688, 5100, 5289, are being worked on together as they all are reporting on the problem.

comment:3 Changed 6 years ago by anonymous

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed by changeset 72855, Fix problem of locale("") exception being thrown before main() starts on misconfigured (e.g. LANG="bad name") POSIX systems. Resolves the most serious aspect of tickets 4688, 5100, 5289.

Boost 1.47.0 was the first release to include this fix.

--Beman

Add Comment

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain bemandawes.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.