Modify

Opened 6 years ago

Closed 21 months ago

#5808 closed Bugs (fixed)

fusion gcc 4.0.0 ICE

Reported by: Ralf W. Grosse-Kunstleve Owned by: t_schwinger
Milestone: Boost 1.61.0 Component: fusion
Version: Boost 1.60.0 Severity: Problem
Keywords: Cc:

Description

Fedora Core release 4 (Stentz) g++ (GCC) 4.0.0 20050519 (Red Hat 4.0.0-8)

simple.cpp: #include <boost/fusion/view/single_view.hpp>

g++ -I$hot/boost simple.cpp

See the error message below. It appears for all boost svn trunk revisions starting with 73854 (tested up to 74022). A workaround would be very helpful.

Ralf

/net/sigma/raid1/rwgk/hot/boost/boost/fusion/view/single_view/detail/next_impl.hpp: In static member function 'static boost::fusion::single_view_iterator<typename Iterator::single_view_type, typename boost::mpl::next<typename Iterator::position>::type> boost::fusion::extension::next_impl<boost::fusion::single_view_iterator_tag>::apply<Iterator>::call(const Iterator&)': /net/sigma/raid1/rwgk/hot/boost/boost/fusion/view/single_view/detail/next_impl.hpp:40: internal compiler error: Segmentation fault Please submit a full bug report, with preprocessed source if appropriate. See <URL:http://bugzilla.redhat.com/bugzilla> for instructions. Preprocessed source stored into /tmp/cc9IZjJY.out file, please attach this to your bugreport.

Attachments (0)

Change History (5)

comment:1 Changed 6 years ago by Eric Niebler

Owner: changed from Eric Niebler to t_schwinger

I can't reproduce this problem because gcc-4.0.0 doesn't build on cygwin for me. There's no further progress I can make on this, sorry. Maybe Tobias can help. A patch would also gladly be accepted.

comment:2 Changed 6 years ago by Ralf W. Grosse-Kunstleve

Thanks for looking into this! The fusion code is too complex for me; I have no idea where to start patching. However, I can provide direct access to the machine with the gcc-4.0.0 compiler. If you want to try this out, please email your public ssh key to rwgrosse-kunstleve@…. Also let me know your preferred account name and shell.

BTW: we have a big selection of platforms: http://cci.lbl.gov/cctbx_build/show_error_summary.cgi?build_tag=2011_08_24_1020 You are welcome to use any of these for testing as long as you like.

comment:3 Changed 21 months ago by Kohei Takahashi <flast@…>

Milestone: To Be DeterminedBoost 1.61.0
Version: Boost Development TrunkBoost 1.60.0

Confirmed. I'll submit a patch to fix this issue (but for post 1.61.0 beta).

comment:4 Changed 21 months ago by Kohei Takahashi <flast@…>

comment:5 Changed 21 months ago by Joel de Guzman

Resolution: fixed
Status: newclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain t_schwinger.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.