Opened 17 years ago

Closed 17 years ago

#6 closed Bugs (Duplicate)

tie in utility.hpp and tuple.hpp clash.

Reported by: nobody Owned by: jmaurer
Milestone: Component: None
Version: None Severity:
Keywords: Cc:

Description

Hi the two declarations of the tie function
in utility.hpp and tuple.hpp are conflicting.
The compiler (KCC) complains about more than
one matching function template (I think 
correctly). Perhaps one should remove tie from
utility.hpp?

Another problem in tuple.hpp are the following 
function declarations:

template<class T0, class T1>
boost::detail::tuples::make_tuple_mapper<T0, T1>::type
inline make_tuple(const T0& t0, const T1& t1) {
  return boost::detail::tuples::make_tuple_mapper<T0, 
T1>::type(t0, t1); 
}

I think it sould be:

template<class T0, class T1>
typename boost::detail::tuples::make_tuple_mapper<T0, 
T1>::type
inline make_tuple(const T0& t0, const T1& t1) {
  return boost::detail::tuples::make_tuple_mapper<T0, 
T1>::type(t0, t1); 
}

At least KCC 4.0 requires this, but I haven't tried on 
any other compilers.

Yours,

Mathias Koerner

Change History (2)

comment:1 Changed 17 years ago by jsiek

Logged In: YES 
user_id=32836

tie() has already been deleted from utility.hpp (see the
current CVS).
Jaakko can handle the other problem...

comment:2 Changed 17 years ago by jmaurer

Status: assignedclosed
Logged In: YES 
user_id=53943

These were fixed post-1.24.0.
Boost version 1.25.0 is due soon.
Otherwise, get the fixed files from our CVS repository.
Note: See TracTickets for help on using tickets.