Opened 6 years ago

Last modified 6 years ago

#6810 new Bugs

boost system auto linking is broken in svn trunk 78080

Reported by: anonymous Owned by: Beman Dawes
Milestone: To Be Determined Component: system
Version: Boost Development Trunk Severity: Problem
Keywords: Cc: joseph@…


I am now getting...

fatal error LNK1104: cannot open file 'boost_system-vc90-mt-gd-1_50.lib'

When I try to build my project. I don't have that library because I am building the default static libraries. (note: not runtime-static). I instead have libboost_system-vc90-mt-gd-1_50.lib. Did somebody who had the non default dynamically linkable libraries on their system check in a breaking change? We have tried manually defining BOOST_ALL_STATIC_LIB but that does not make a difference. When we manually define BOOST_ALL_NO_LIB that does remove this error but adds a bunch of undefined symbols that are not the obvious location. IE: boost::filesystem::path_traits::convert... does not appear to be in libboost_filesystem.

my libraries are built with simply bootstrap.bat b2 --toolset=msvc-9.0

Change History (4)

comment:1 Changed 6 years ago by anonymous

Version: Boost 1.48.0Boost Development Trunk

comment:2 Changed 6 years ago by Joseph Southwell <joseph@…>

Cc: joseph@… added

comment:3 Changed 6 years ago by Joseph Southwell <joseph@…>

It seems that BOOST_ALL_STATIC_LIB was wrong, BOOST_ALL_STATIC_LINK worked. It was not required before however. Perhaps this was intentional. But, It seems that whatever the default is when you build with b2, the same default should exist in the auto linking.

comment:4 Changed 6 years ago by viboes

Component: Nonesystem
Owner: set to Beman Dawes
Note: See TracTickets for help on using tickets.