Modify

Opened 6 years ago

Closed 5 years ago

#6922 closed Bugs (fixed)

gcc -Wcast-align warning in boost/intrusive

Reported by: stieber.c@… Owned by: Ion Gaztañaga
Milestone: To Be Determined Component: intrusive
Version: Boost 1.49.0 Severity: Cosmetic
Keywords: intrusive containers, member hook, alignment warning Cc:

Description

When I tried to use boost::intrusive::set with a member hook, I got this warning (I use reasonably aggressive warning settings):

../../Boost/boost/intrusive/detail/parent_from_member.hpp:50:9: error: cast from 'char *' to 'CSBuilder::Project *'

increases required alignment from 1 to 8 [-Werror,-Wcast-align]

return (Parent*)((char*)member - offset_from_pointer_to_member(ptr_to_member));

I didn't dig into that code, but judging from the identifiers it seems to do the right thing, and it would seem that the warning is not caused by me doing something bad (unless you count using boost or enabling warnings as 'bad'). Thus, suppressing the warning is probably ok. Just insert an additional (void*) cast like this:

return (Parent*)(void*)((char*)member...

If other compilers "see through" that and still issue such warnings, somebody with more compiler-experience can probably come up with a better way.

Attachments (0)

Change History (1)

comment:1 Changed 5 years ago by Ion Gaztañaga

Resolution: fixed
Status: newclosed

Thanks for the report, it was corrected in trunk at revision 78588

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Ion Gaztañaga.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.