Modify

Opened 5 years ago

Closed 5 years ago

#7051 closed Bugs (fixed)

boost::filesystem compile error on solaris 10

Reported by: robin.nicholson@… Owned by: bemandawes
Milestone: To Be Determined Component: filesystem
Version: Boost 1.50.0 Severity: Problem
Keywords: compile error Cc: duncanphilipnorman@…

Description

fails to compile because fchmodat is not supported on solaris 10. (Compiler used was gcc 4.7.1)

libs/filesystem/src/operations.cpp: In function 'void boost_1_50_0::filesystem::detail::permissions(const boost_1_50_0::filesystem::path&, boost_1_50_0::filesystem::perms, boost_1_50_0::system::error_code*)': libs/filesystem/src/operations.cpp:1401:11: error: '::fchmodat' has not been declared

uname -a SunOS 5.10 Generic_141444-09 sun4u sparc SUNW,Sun-Fire-V490

Attachments (0)

Change History (3)

comment:1 Changed 5 years ago by Duncan Exon Smith <duncanphilipnorman@…>

  • Cc duncanphilipnorman@… added

This looks like a duplicate of #6659... you may want to add your testcase to that bug (although it has been ignored for 4 months).

comment:2 Changed 5 years ago by anonymous

The issue has been addresses before but not for compiling with gcc on solaris line 1400 could have

&& !defined(sun)

added to it to fix the problem

comment:3 Changed 5 years ago by bemandawes

  • Resolution set to fixed
  • Status changed from new to closed

(In [79484]) Fix #6659 and #7051, fchmodat supported only on Solaris 11. Disable fchmodat for both Sun and GCC compilers regardless of OS version; a runtime check is too much trouble.

Add Comment

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain bemandawes.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.