Modify

Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#7155 closed Feature Requests (fixed)

Graph's GraphML reader mistreats <key for="graphml"> as erroneous

Reported by: alex@… Owned by:
Milestone: To Be Determined Component: graph
Version: Boost 1.51.0 Severity: Optimization
Keywords: BGL, GraphML Cc:

Description

The GraphML specification specifies (see definition of simpleType name="key.for.type" the file graphml-structure.xsd on the GraphML Homepage, which I cannot link due to the spam protection) that

<graphml ...>
  <key for="graphml" id="d0" ... />
  ...

is a valid "for" attribute. The graphml parser in lib/graph/graphml.cpp throws an error:

terminate called after throwing an instance of 'boost::exception_detail::clone_impl<boost::exception_detail::error_info_injector<boost::parse_error> >'
  what():  parse error: Attribute for is not valid: graphml
Aborted

Attachments (1)

graphml.diff (712 bytes) - added by alex@… 5 years ago.
Patch

Download all attachments as: .zip

Change History (3)

Changed 5 years ago by alex@…

Patch

comment:1 Changed 5 years ago by jewillco

  • Component changed from None to graph
  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #7016.

comment:2 Changed 4 years ago by jewillco

  • Resolution changed from duplicate to fixed

(In [83961]) Applied patch from #7155 to add "graphml" as a value for "for"; fixes #7155; fixes #7016

Add Comment

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.