Modify

Opened 11 years ago

Closed 11 years ago

#777 deleted Bugs (Duplicate)

top-level configure is broken

Reported by: eponym Owned by: nobody
Milestone: Component: build
Version: Boost 1.34.0 Severity:
Keywords: Cc:

Description

The top-level configure script in the RC1.34.0 release
is broken.

This script starts out as:

    #!/bin/sh

which implies that it is a Bourne-shell script.
But now almost all of tests in the file have been
converted to look like the following:

    220 if test "x$LIBDIR" == x; then
    221   LIBDIR="$EPREFIX/lib"
    222 fi

where (in 1.33.1) they used to look like this:

    217 if test "x$LIBDIR" = "x" ; then
    218   LIBDIR="$EPREFIX/lib"
    219 fi

The problem is that "==" is not a valid Bourne-shell
test-command operator, so the entire build breaks
immediately on any platform which uses a true
Bourne shell as sh.

The fix is to either convert all of these operators
to "=", or to stop claiming the script is a Bourne
shell script and use "#!/bin/bash" instead.  But the
latter approach is not recommended because there are
many older machines without bash in that location.

Attachments (0)

Change History (1)

comment:1 Changed 11 years ago by eponym

Status: assignedclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as deleted The owner will remain nobody.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.