Modify

Opened 11 years ago

Closed 10 years ago

#778 closed Bugs (fixed)

top-level configure is broken

Reported by: eponym Owned by: Aaron Windsor
Milestone: Boost 1.36.0 Component: build
Version: Boost 1.34.0 Severity: Showstopper
Keywords: Cc:

Description (last modified by John Maddock)

The top-level configure script in the RC1.34.0 release
is broken.

This script starts out as:

    #!/bin/sh

which implies that it is a Bourne-shell script.
But now almost all of tests in the file have been
converted to look like the following:

    220 if test "x$LIBDIR" == x; then
    221   LIBDIR="$EPREFIX/lib"
    222 fi

where (in 1.33.1) they used to look like this:

    217 if test "x$LIBDIR" = "x" ; then
    218   LIBDIR="$EPREFIX/lib"
    219 fi

The problem is that "==" is not a valid Bourne-shell
test-command operator, so the entire build breaks
immediately on any platform which uses a true
Bourne shell as sh.

The fix is to either convert all of these operators
to "=", or to stop claiming the script is a Bourne
shell script and use "#!/bin/bash" instead.  But the
latter approach is not recommended because there are
many older machines without bash in that location.

Attachments (0)

Change History (3)

comment:1 Changed 11 years ago by eponym

Status: assignedclosed

comment:2 Changed 10 years ago by John Maddock

Description: modified (diff)
Milestone: Boost 1.35.0
Severity: Showstopper

comment:3 Changed 10 years ago by Daniel James

Resolution: Duplicatefixed
Status: assignedclosed

This was fixed in changeset [36346].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Aaron Windsor.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.