Modify

Opened 4 years ago

Closed 4 years ago

#8197 closed Bugs (fixed)

range/algorithm conflicts with polygon

Reported by: Stepan Podoskin <stepik-777@…> Owned by: asydorchuk
Milestone: Boost 1.55.0 Component: polygon
Version: Boost 1.53.0 Severity: Problem
Keywords: Cc:

Description

This fails to compile on GCC 4.7.2 (MinGW) but it can be compiled with MSVC 2010.

#include <boost/range/algorithm.hpp>
#include <boost/polygon/polygon.hpp>

Reversing order of includes fixes the problem. (It seems that boost/polygon documentation doesn't mention what headers should be included to use it so I just included polygon.hpp). GCC output attached.

Attachments (2)

gcc-output.txt (3.8 KB) - added by Stepan Podoskin <stepik-777@…> 4 years ago.
Output from GCC
8197.patch (856 bytes) - added by asydorchuk 4 years ago.

Download all attachments as: .zip

Change History (12)

Changed 4 years ago by Stepan Podoskin <stepik-777@…>

Output from GCC

comment:1 Changed 4 years ago by marshall

Interesting. Compiling with clang (and libc++), I don't get this error.

Just to be clear: I do get the error with gcc 4.7.2

Last edited 4 years ago by marshall (previous) (diff)

comment:2 Changed 4 years ago by viboes

  • Component changed from None to polygon
  • Owner set to ljsimons

comment:3 Changed 4 years ago by asydorchuk

  • Owner changed from ljsimons to asydorchuk

comment:4 Changed 4 years ago by asydorchuk

  • Milestone changed from To Be Determined to Boost 1.54.0
  • Resolution set to fixed
  • Status changed from new to closed

comment:5 Changed 4 years ago by asydorchuk

The issue is fixed on trunk and will go into Boost 1.54 release.

comment:6 Changed 4 years ago by asydorchuk

(In [83918]) [Polygon] Merging from trunk for the upcoming release: 1) Updated Voronoi documentation. 2) Fixed #8026, #8197, #8257.

comment:7 Changed 4 years ago by Stepan Podoskin <stepik-777@…>

  • Resolution fixed deleted
  • Status changed from closed to reopened

I still have this problem with boost 1.54.0 and gcc-4.8.1.

Changed 4 years ago by asydorchuk

comment:8 Changed 4 years ago by asydorchuk

You are right, the fix was not merged successfully from trunk to release branch. I've just merged the fix into the release branch, and it will go live with the next release. Meanwhile, please use the patch (8197.patch) attached to this bug report.

comment:9 Changed 4 years ago by asydorchuk

  • Milestone changed from Boost 1.54.0 to Boost 1.55.0
  • Status changed from reopened to new

comment:10 Changed 4 years ago by asydorchuk

  • Resolution set to fixed
  • Status changed from new to closed

Add Comment

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain asydorchuk.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.