Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#8294 closed Bugs (fixed)

deque::insert(const_iterator, Itr, Itr) misbehavior

Reported by: expaler Owned by: igaztanaga
Milestone: To Be Determined Component: container
Version: Boost 1.53.0 Severity: Problem
Keywords: Cc:

Description

When the const_iterator argument points to a valid position in the deque that is not past-the-end, the range elements are inserted in the wrong order.

Attachments (1)

deque_insert_range.cpp (1.7 KB) - added by expaler 4 years ago.
This test program compares the behavior of boost::container::deque with that of std::deque. Currently it reports errors at lines 40 and 41, after range insertion into the boost::container::deque. Note that using single-element insertion into the boost::container::deque to accomplish the desired result works as intended.

Download all attachments as: .zip

Change History (3)

Changed 4 years ago by expaler

This test program compares the behavior of boost::container::deque with that of std::deque. Currently it reports errors at lines 40 and 41, after range insertion into the boost::container::deque. Note that using single-element insertion into the boost::container::deque to accomplish the desired result works as intended.

comment:1 Changed 4 years ago by igaztanaga

  • Resolution set to fixed
  • Status changed from new to closed

Thanks for the report and the test case. Fixed in revision #83467.

comment:2 Changed 4 years ago by anonymous

Oh, okay. Thanks!

Add Comment

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain igaztanaga.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.