Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#8411 closed Bugs (fixed)

Boost 1.53.0: libboost_graph_parallel.so fails to build in C++11 mode

Reported by: Arfrever.FTA@… Owned by: Jeremiah Willcock
Milestone: Boost 1.54.0 Component: graph
Version: Boost 1.53.0 Severity: Regression
Keywords: Cc: Arfrever.FTA@…

Description

libboost_graph_parallel.so in Boost 1.53.0 fails to build in C++11 mode. This bug does not occur in Boost 1.52.0. I use GCC 4.7.2.

gcc.compile.c++ bin.v2/libs/graph_parallel/build/gcc-4.7/gentoorelease/pch-off/threading-multi/mpi_process_group.o

    "x86_64-pc-linux-gnu-g++"  -ftemplate-depth-128 -march=core2 -O2 -pipe -std=gnu++11 -finline-functions -Wno-inline -Wall -pthread -fPIC  -DBOOST_ALL_NO_LIB=1 -DBOOST_GRAPH_DYN_LINK=1 -DBOOST_GRAPH_NO_LIB=1 -DNDEBUG  -I"." -I"libs/graph_parallel/src" -c -o "bin.v2/libs/graph_parallel/build/gcc-4.7/gentoorelease/pch-off/threading-multi/mpi_process_group.o" "libs/graph_parallel/src/mpi_process_group.cpp"

In file included from libs/graph_parallel/src/mpi_process_group.cpp:14:0:
./boost/graph/distributed/mpi_process_group.hpp: In member function ‘boost::graph::distributed::mpi_process_group::operator bool()’:
./boost/graph/distributed/mpi_process_group.hpp:419:28: error: cannot convert ‘boost::shared_ptr<boost::graph::distributed::mpi_process_group::impl>’ to ‘bool’ in return

Attachments (0)

Change History (6)

comment:1 Changed 5 years ago by Jeremiah Willcock

Does it still fail with the trunk version of Boost? I have seen errors like that from several other libraries that have since been resolved, and I believe the issue was not specific to Boost.Graph.

comment:2 Changed 5 years ago by Arfrever.FTA@…

This bug still occurs in Boost trunk.

comment:3 Changed 5 years ago by Jeremiah Willcock

Resolution: fixed
Status: newclosed

(In [83799]) Added explicit conversion to make code with in C++11 mode; fixes #8411

comment:4 Changed 5 years ago by anonymous

Please backport this change to release branch.

comment:5 Changed 5 years ago by Jeremiah Willcock

I'll try to get it into the next release. Otherwise, you can download the trunk version or I can create a patch to use for now.

comment:6 Changed 5 years ago by Arfrever.FTA@…

The patch works for me. It would be nice if applying additional patch was not needed in Boost 1.54.0.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jeremiah Willcock.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.