Modify

Opened 4 years ago

Closed 4 years ago

#8959 closed Feature Requests (fixed)

BOOST_ASIO_HAS_MOVE should be defined for MSVC 12 and above.

Reported by: smueller@… Owned by: chris_kohlhoff
Milestone: To Be Determined Component: asio
Version: Boost 1.53.0 Severity: Problem
Keywords: Cc:

Description

I needed the ability to perform move construction for basic_io_object instances.

Explicitly defining BOOST_ASIO_HAS_MOVE is the workaround, but it would be good to modify ASIO's config.hpp to handle MSVC 12.

Attachments (3)

config.hpp.patch (856 bytes) - added by smueller@… 4 years ago.
MSVC 12 detection to define BOOST_ASIO_HAS_MOVE
config.hpp (31.6 KB) - added by smueller@… 4 years ago.
Fixed patch to reflect proper _MSC_VER definitions
config.hpp.2.patch (1.1 KB) - added by smueller@… 4 years ago.
Actual fixed patch to reflect MSC_VER changes. (Beware touch screens, early adopters.)

Download all attachments as: .zip

Change History (5)

Changed 4 years ago by smueller@…

Attachment: config.hpp.patch added

MSVC 12 detection to define BOOST_ASIO_HAS_MOVE

comment:1 Changed 4 years ago by smueller@…

This is a duplicate of #8750.

Changed 4 years ago by smueller@…

Attachment: config.hpp added

Fixed patch to reflect proper _MSC_VER definitions

Changed 4 years ago by smueller@…

Attachment: config.hpp.2.patch added

Actual fixed patch to reflect MSC_VER changes. (Beware touch screens, early adopters.)

comment:2 Changed 4 years ago by chris_kohlhoff

Resolution: fixed
Status: newclosed

Fixed on trunk in [85766]. Merged to release in [85838]

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain chris_kohlhoff.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.