Modify

Opened 4 years ago

Closed 4 years ago

#8973 closed Bugs (fixed)

compiling with 1.54.0 with gcc 4.8.1 fails with uintptr_t type not declared.

Reported by: j.e.vasquez.v@… Owned by: timblechmann
Milestone: To Be Determined Component: atomic
Version: Boost 1.54.0 Severity: Problem
Keywords: Cc: j.e.vasquez.v@…

Description

When compiling boost 1.54.0 with gcc 4.8.1 I gett the following error:

gcc.compile.c++ bin.v2/libs/atomic/build/gcc-4.8.1/release/threading-multi/lockpool.o In file included from ./boost/atomic.hpp:12:0,

from libs/atomic/src/lockpool.cpp:1:

./boost/atomic/atomic.hpp:202:16: error: 'uintptr_t' was not declared in this scope

typedef atomic<uintptr_t> atomic_uintptr_t;

./boost/atomic/atomic.hpp:202:25: error: template argument 1 is invalid

typedef atomic<uintptr_t> atomic_uintptr_t;

./boost/atomic/atomic.hpp:202:43: error: invalid type in declaration before ';' token

typedef atomic<uintptr_t> atomic_uintptr_t;

"g++" -ftemplate-depth-128 -Wno-strict-aliasing -march=native -mtune=native -m64 -pipe -DPIC -fPIC -O3 -O3 -finline-functions -Wno-inline -Wall -pthread -fPIC -DBOOST_ALL_NO_LIB=1 -DBOOST_ATOMIC_DYN_LINK=1 -DBOOST_ATOMIC_SOURCE -DNDEBUG -I"." -c -o "bin.v2/libs/atomic/build/gcc-4.8.1/release/threading-multi/lockpool.o" "libs/atomic/src/lockpool.cpp"

...failed gcc.compile.c++ bin.v2/libs/atomic/build/gcc-4.8.1/release/threading-multi/lockpool.o... ...failed updating 1 target... ...updated 7 targets...

Attachments (1)

boost-1_54_0.xz (1.6 KB) - added by anonymous 4 years ago.

Download all attachments as: .zip

Change History (9)

Changed 4 years ago by anonymous

comment:1 Changed 4 years ago by anonymous

I just attached the log file...

comment:3 Changed 4 years ago by anonymous

You are right... With:

% svn info . ... Repository Root: http://svn.boost.org/svn/boost ... Revision: 85256 ...

boost does compile/install OK...

comment:4 Changed 4 years ago by viboes

  • Component changed from Building Boost to atomic
  • Owner set to timblechmann

comment:5 Changed 4 years ago by hongli@…

This bug is a duplicate of https://svn.boost.org/trac/boost/ticket/7979. I've posted new comments there.

comment:6 Changed 4 years ago by timblechmann

can you test boost-trunk?

comment:7 Changed 4 years ago by hongli@…

Yes boost-trunk compiles without problems.

comment:8 Changed 4 years ago by timblechmann

  • Resolution set to fixed
  • Status changed from new to closed

Add Comment

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain timblechmann.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.