Modify

Opened 4 years ago

Closed 4 years ago

#9050 closed Bugs (fixed)

Log test executables setup_*.exe trigger Windows7 UAC

Reported by: Jim Bell <jim@…> Owned by: Andrey Semashev
Milestone: To Be Determined Component: log
Version: Boost Development Trunk Severity: Regression
Keywords: Windows7 UAC setup Cc: jim@…

Description

Three log regression tests create executables named "setup_....exe", but that name triggers the Windows7 UAC (User Account Control) mechanism, which darkens the entire screen and puts up this dialog:

Do you want to allow the following program from an unknown publisher
to make changes to this computer?

The programs are:

  • setup_settings_parser.exe
  • setup_formatter_parser.exe
  • setup_filter_parser.exe

Renaming them to change "setup_..." to something else (such as "stp_..." or "ready_..." or some such) will allow them to run without altering the UAC settings on each regression-test machine.

See also lists.boost.org/boost-testing/2013/08/7317.php

Though this seems to be based on the file's name, I don't think all the rules employed by Windows' UAC mechanism are formally documented even by Microsoft.

Attachments (0)

Change History (2)

comment:1 Changed 4 years ago by Andrey Semashev

(In [85476]) Worked around compilation problem with clang. Renamed parsers tests to avoid alarming Windows UAC. Refs #9050.

comment:2 Changed 4 years ago by Andrey Semashev

Resolution: fixed
Status: newclosed

(In [85477]) Worked around compilation problem with clang. Renamed parsers tests to avoid alarming Windows UAC. Fixes #9050.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Andrey Semashev.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.